75c895bd71a8688e0d73bb0acf6cb66e0258b31d
[gentoo.git] / media-gfx / splash-themes-livecd / splash-themes-livecd-2005.1.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 MY_P="gentoo-livecd-${PV}"
5 MY_REV="0.9.2"
6 DESCRIPTION="Gentoo theme for gensplash consoles"
7 HOMEPAGE="https://www.gentoo.org/"
8 SRC_URI="https://dev.gentoo.org/~wolf31o2/sources/${PN}/${MY_P}-${MY_REV}.tar.bz2"
9
10 SLOT=${PV}
11 LICENSE="Artistic GPL-2 BitstreamVera"
12 KEYWORDS="amd64 ~ppc x86"
13 IUSE=""
14 RESTRICT="binchecks strip"
15
16 DEPEND=">=media-gfx/splashutils-1.1.9.7"
17
18 S="${WORKDIR}/${MY_P}"
19
20 src_unpack() {
21         unpack ${A}
22         cd "${S}"
23         sed -i -e '/^\/bin\/umount -l "\/etc\/splash\/${SPLASH_THEME}"$/s/^\(.*\)$/\1 \&>\/dev\/null/' scripts/rc_exit-post
24         sed -i -e 's-/sbin/functions.sh-/etc/init.d/functions.sh-' scripts/rc_init-pre
25 }
26
27 src_install() {
28         dodir /etc/splash/livecd-${PV}
29         cp -r "${S}"/* "${D}"/etc/splash/livecd-${PV}
30 }