*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / media-gfx / sigal / sigal-1.3.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Simple static web gallery generator"
10 HOMEPAGE="http://sigal.saimon.org/"
11 SRC_URI="https://github.com/saimn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="s3 test"
17 RESTRICT="!test? ( test )"
18
19 CDEPEND="dev-python/blinker[${PYTHON_USEDEP}]
20         dev-python/click[${PYTHON_USEDEP}]
21         dev-python/jinja[${PYTHON_USEDEP}]
22         dev-python/markdown[${PYTHON_USEDEP}]
23         dev-python/pillow[${PYTHON_USEDEP}]
24         dev-python/pilkit[${PYTHON_USEDEP}]"
25 DEPEND="${CDEPEND}
26         s3? ( dev-python/boto[${PYTHON_USEDEP}] )
27         test? (
28                 dev-python/boto[${PYTHON_USEDEP}]
29                 dev-python/pytest[${PYTHON_USEDEP}]
30         )"
31 RDEPEND="${CDEPEND}"
32
33 DOCS="README.rst"
34
35 python_test() {
36         esetup.py test
37 }