*/*: Drop stable ia64 keywords
[gentoo.git] / media-gfx / qrencode / qrencode-4.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="C library for encoding data in a QR Code symbol"
7 HOMEPAGE="https://fukuchi.org/works/qrencode/"
8 SRC_URI="https://fukuchi.org/works/${PN}/${P}.tar.bz2"
9
10 LICENSE="LGPL-2"
11 SLOT="0/4"
12 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
13 IUSE="test"
14 RESTRICT="!test? ( test )"
15
16 RDEPEND="media-libs/libpng:0="
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig"
19
20 src_configure() {
21         local myconf=(
22                 $(use_with test tests)
23                 # TODO: figure out how to make SDL check fail as the SDL test
24                 # program is not useful
25         )
26
27         econf "${myconf[@]}"
28 }
29
30 src_test() {
31         cd tests || die
32         ./test_basic.sh || die
33 }
34
35 src_install() {
36         default
37         find "${D}" -name '*.la' -delete || die
38 }