8d84d1356b309a1c5453a007e11d5a4977d5c97c
[gentoo.git] / media-gfx / mscgen / mscgen-0.20.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="A message sequence chart generator"
9 HOMEPAGE="http://www.mcternan.me.uk/mscgen/"
10 SRC_URI="http://www.mcternan.me.uk/${PN}/software/${PN}-src-${PV}.tar.gz"
11
12 KEYWORDS="amd64 arm ppc ppc64 x86 ~x64-solaris"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE="png truetype"
17
18 RDEPEND="png? ( media-libs/gd[png,truetype?] )"
19 DEPEND="${RDEPEND}
20         virtual/pkgconfig
21         sys-devel/bison
22         sys-devel/flex"
23
24 # Workaround for bug #379279
25 RESTRICT="test"
26
27 src_prepare() {
28         sed -i -e '/dist_doc_DATA/d' Makefile.am || die "Fixing Makefile.am failed"
29         eautoreconf
30         eapply_user
31 }
32
33 src_configure() {
34         local myconf
35
36         if use png; then
37                 use truetype && myconf="--with-freetype"
38         else
39                 myconf="--without-png"
40         fi
41
42         econf \
43                 --docdir="${EPREFIX}"/usr/share/doc/${PF} \
44                 ${myconf}
45 }