*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / media-gfx / img2pdf / img2pdf-0.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Losslessly convert raster images to PDF"
11 HOMEPAGE="https://gitlab.mister-muffin.de/josch/img2pdf"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="LGPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18 RESTRICT="!test? ( test )"
19
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
21         test? ( dev-python/pdfrw[${PYTHON_USEDEP}] )"
22 RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
23
24 python_test() {
25         esetup.py test
26 }