sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / media-gfx / gnome-screenshot / gnome-screenshot-3.36.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit gnome.org gnome2-utils meson readme.gentoo-r1 xdg
6
7 DESCRIPTION="Screenshot utility for GNOME"
8 HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-screenshot"
9
10 LICENSE="GPL-2+"
11 SLOT="0"
12 IUSE=""
13 KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
14
15 # libcanberra 0.26-r2 is needed for gtk+:3 fixes
16 DEPEND="
17         x11-libs/libX11
18         x11-libs/libXext
19         >=dev-libs/glib-2.35.1:2[dbus]
20         >=x11-libs/gtk+-3.12.0:3
21         >=media-libs/libcanberra-0.26-r2[gtk3]
22 "
23 RDEPEND="${DEPEND}
24         >=gnome-base/gsettings-desktop-schemas-0.1.0
25 "
26 BDEPEND="
27         dev-libs/appstream-glib
28         dev-libs/libxml2:2
29         >=sys-devel/gettext-0.19.8
30         virtual/pkgconfig
31         x11-base/xorg-proto
32 "
33
34 DOC_CONTENTS="${P} saves screenshots in ~/Pictures/ and defaults to
35         non-interactive mode when launched from a terminal. If you want to choose
36         where to save the screenshot, run 'gnome-screenshot --interactive'"
37
38 src_install() {
39         meson_src_install
40         readme.gentoo_create_doc
41 }
42
43 pkg_postinst() {
44         xdg_pkg_postinst
45         gnome2_schemas_update
46         readme.gentoo_print_elog
47 }
48
49 pkg_postrm() {
50         xdg_pkg_postrm
51         gnome2_schemas_update
52 }