*/*: Bump copyright on files touched this year
[gentoo.git] / media-fonts / pcf2bdf / pcf2bdf-1.04-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Converts PCF fonts to BDF fonts"
9 HOMEPAGE="http://www.tsg.ne.jp/GANA/S/pcf2bdf/"
10 SRC_URI="http://www.tsg.ne.jp/GANA/S/pcf2bdf/${P}.tgz"
11
12 LICENSE="MIT"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm hppa ia64 ~ppc s390 sh sparc x86"
15 IUSE=""
16
17 S=${WORKDIR}
18
19 PATCHES=(
20         "${FILESDIR}"/${P}-64bit.patch
21         "${FILESDIR}"/${P}-gzip.patch
22 )
23
24 src_compile() {
25         emake -f Makefile.gcc CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}"
26 }
27
28 src_install() {
29         emake -f Makefile.gcc \
30                 PREFIX="${ED}/usr" \
31                 MANPATH="${ED}/usr/share/man/man1" \
32                 install
33 }