sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / mate-extra / mate-sensors-applet / mate-sensors-applet-1.22.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MATE_LA_PUNT="yes"
7
8 inherit mate
9
10 if [[ ${PV} != 9999 ]]; then
11         KEYWORDS="amd64 ~arm x86"
12 fi
13
14 DESCRIPTION="MATE panel applet to display readings from hardware sensors"
15 LICENSE="FDL-1.1+ GPL-2+"
16 SLOT="0"
17
18 IUSE="+dbus hddtemp libnotify lm-sensors video_cards_nvidia"
19
20 COMMON_DEPEND=">=dev-libs/glib-2.50:2
21         >=mate-base/mate-panel-1.17.0
22         >=x11-libs/cairo-1.0.4
23         x11-libs/gdk-pixbuf:2
24         >=x11-libs/gtk+-3.22:3
25         virtual/libintl
26         hddtemp? ( >=app-admin/hddtemp-0.3_beta13 )
27         libnotify? ( >=x11-libs/libnotify-0.7 )
28         lm-sensors? ( sys-apps/lm-sensors )
29         video_cards_nvidia? ( || (
30                 >=x11-drivers/nvidia-drivers-100.14.09:0[static-libs,tools]
31         ) )"
32
33 RDEPEND="${COMMON_DEPEND}"
34
35 DEPEND="${COMMON_DEPEND}
36         app-text/rarian
37         >=app-text/scrollkeeper-dtd-1:1.0
38         app-text/yelp-tools
39         >=dev-util/intltool-0.50.1:*
40         sys-devel/gettext:*
41         virtual/pkgconfig:*"
42
43 PDEPEND="hddtemp? ( dbus? ( sys-fs/udisks:2 ) )"
44
45 src_configure() {
46         local udisks
47
48         if use hddtemp && use dbus; then
49                 udisks="--enable-udisks2"
50         else
51                 udisks="--disable-udisks2"
52         fi
53
54         mate_src_configure \
55                 --disable-netbsd \
56                 --disable-static \
57                 --without-aticonfig \
58                 $(use_enable libnotify) \
59                 $(use_with lm-sensors libsensors) \
60                 $(use_with video_cards_nvidia nvidia) \
61                 ${udisks}
62 }