sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / mate-extra / mate-polkit / mate-polkit-1.22.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit mate
7
8 if [[ ${PV} != 9999 ]]; then
9         KEYWORDS="amd64 ~arm ~arm64 x86"
10 fi
11
12 DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
13 LICENSE="LGPL-2+"
14 SLOT="0"
15
16 IUSE="accountsservice appindicator"
17
18 COMMON_DEPEND=">=dev-libs/glib-2.50:2
19         >=sys-auth/polkit-0.102
20         x11-libs/gdk-pixbuf:2
21         virtual/libintl:0
22         >=x11-libs/gtk+-3.22.0:3
23         appindicator? ( dev-libs/libappindicator:3 )"
24
25 RDEPEND="${COMMON_DEPEND}
26         accountsservice? ( sys-apps/accountsservice )"
27
28 DEPEND="${COMMON_DEPEND}
29         dev-util/gtk-doc
30         dev-util/gtk-doc-am
31         >=dev-util/intltool-0.35:*
32         sys-devel/gettext:*
33         >=sys-devel/libtool-2.2.6
34         virtual/pkgconfig:*
35         !<gnome-extra/polkit-gnome-0.102:0"
36
37 src_configure() {
38         mate_src_configure \
39                 --disable-static \
40                 $(use_enable accountsservice) \
41                 $(use_enable appindicator)
42 }