252fefa01fceea8c021b62eeef03fad53f4f66f1
[gentoo.git] / kde-apps / kontact / kontact-4.14.8.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KDE_HANDBOOK="optional"
8 KMNAME="kdepim"
9 EGIT_BRANCH="KDE/4.14"
10 inherit kde4-meta
11
12 DESCRIPTION="KDE personal information manager"
13 HOMEPAGE="https://www.kde.org/applications/office/kontact/"
14 KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
15 IUSE="debug"
16
17 DEPEND="
18         $(add_kdeapps_dep kdepimlibs)
19         $(add_kdeapps_dep kdepim-common-libs)
20 "
21 RDEPEND="${DEPEND}"
22
23 KMLOADLIBS="kdepim-common-libs"
24 KMSAVELIBS="true"
25
26 # We remove plugins that are related to external kdepim programs. This way
27 # kontact doesn't have to depend on all programs it has plugins for.
28 # kcontactmanager gone from kdesvn
29 #
30 KMEXTRACTONLY="
31         kontact/plugins/akregator/
32         kontact/plugins/kaddressbook/
33         kontact/plugins/kjots/
34         kontact/plugins/kmail/
35         kontact/plugins/knode/
36         kontact/plugins/knotes/
37         kontact/plugins/korganizer/
38         kontact/plugins/ktimetracker/
39         kontact/plugins/planner/
40         kontact/plugins/specialdates/
41         libkdepimdbusinterfaces/
42 "
43
44 src_unpack() {
45         if use handbook; then
46                 KMEXTRA+="
47                         doc/kontact-admin/
48                 "
49         fi
50
51         kde4-meta_src_unpack
52 }