Drop ppc and ppc64 to testing in KDE-related packages.
[gentoo.git] / kde-apps / kdebase-data / kdebase-data-4.14.3-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 KMNAME="kde-runtime"
8 KMNOMODULE="true"
9 inherit kde4-meta
10
11 DESCRIPTION="Icons, localization data and various .desktop files from kdebase"
12 IUSE="+wallpapers"
13 KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
14
15 RDEPEND="
16         wallpapers? ( $(add_kdeapps_dep kde-wallpapers) )
17         x11-themes/hicolor-icon-theme
18 "
19
20 KMEXTRA="
21         l10n/
22         localization/
23         pics/
24 "
25 # Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
26 KMEXTRACTONLY="
27         config-runtime.h.cmake
28         kde4
29 "
30
31 PATCHES=( "${FILESDIR}/${P}-lithuania-euro.patch" )
32
33 src_configure() {
34         # Remove remnants of hicolor-icon-theme
35         sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
36                 -i pics/CMakeLists.txt \
37                 || die "failed to remove remnants of hicolor-icon-theme"
38
39         kde4-meta_src_configure
40 }