sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / gnustep-base / gnustep-back-xlib / gnustep-back-xlib-0.26.2.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnustep-base
6
7 DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library"
8 HOMEPAGE="http://www.gnustep.org"
9 SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
10
11 LICENSE="LGPL-2.1"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
14 IUSE="opengl xim"
15
16 RDEPEND="${GNUSTEP_CORE_DEPEND}
17         =gnustep-base/gnustep-gui-${PV%.*}*
18         opengl? ( virtual/opengl virtual/glu )
19         x11-libs/libICE
20         x11-libs/libSM
21         x11-libs/libX11
22         x11-libs/libXext
23         x11-libs/libXi
24         x11-libs/libXmu
25         x11-libs/libXt
26         x11-libs/libXft
27         x11-libs/libXrender
28         >=media-libs/freetype-2.1.9
29
30         !gnustep-base/gnustep-back-art
31         !gnustep-base/gnustep-back-cairo"
32 DEPEND="${RDEPEND}"
33
34 S=${WORKDIR}/gnustep-back-${PV}
35
36 src_configure() {
37         egnustep_env
38
39         myconf="$(use_enable opengl glx)"
40         myconf="$myconf $(use_enable xim)"
41         myconf="$myconf --enable-server=x11"
42         myconf="$myconf --enable-graphics=xlib"
43
44         econf $myconf
45 }