*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / gnome-extra / gnome-tweaks / gnome-tweaks-3.32.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7} )
6
7 inherit gnome.org meson python-single-r1 xdg
8
9 DESCRIPTION="Customize advanced GNOME 3 options"
10 HOMEPAGE="https://wiki.gnome.org/Apps/Tweaks"
11
12 LICENSE="GPL-3+ CC0-1.0"
13 SLOT="0"
14
15 IUSE=""
16 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
17
18 KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 x86"
19
20 COMMON_DEPEND="
21         ${PYTHON_DEPS}
22 "
23 # See README.md for list of deps
24 RDEPEND="${COMMON_DEPEND}
25         >=dev-python/pygobject-3.10.2:3[${PYTHON_USEDEP}]
26         >=gnome-base/gnome-settings-daemon-3
27         x11-themes/sound-theme-freedesktop
28
29         >=dev-libs/glib-2.58:2
30         >=x11-libs/gtk+-3.12:3[introspection]
31         >=gnome-base/gnome-desktop-3.30:3[introspection]
32         net-libs/libsoup:2.4[introspection]
33         x11-libs/libnotify[introspection]
34
35         >=gnome-base/gsettings-desktop-schemas-3.28
36         >=gnome-base/gnome-shell-3.24
37         x11-wm/mutter
38 "
39 DEPEND="${COMMON_DEPEND}"
40 BDEPEND=">=sys-devel/gettext-0.19.8"
41
42 PATCHES=(
43         "${FILESDIR}"/3.28.1-gentoo-cursor-themes.patch # Add contents of Gentoo's cursor theme directory to cursor theme list
44 )
45
46 src_install() {
47         meson_src_install
48         python_fix_shebang "${ED}"/usr/bin/
49 }