sys-process/glances: 3.1.4.1-r1 amd64 stable, bug #720368
[gentoo.git] / gnome-extra / gnome-clocks / gnome-clocks-3.34.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit gnome.org gnome2-utils meson vala xdg
6
7 DESCRIPTION="Clocks application for GNOME"
8 HOMEPAGE="https://wiki.gnome.org/Apps/Clocks"
9
10 LICENSE="GPL-2+"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE=""
14
15 RDEPEND="
16         >=dev-libs/glib-2.44:2
17         >=dev-libs/libgweather-3.27.2:2=
18         >=gnome-base/gnome-desktop-3.8:3=
19         >=media-libs/gsound-0.98
20         >=sci-geosciences/geocode-glib-1
21         >=app-misc/geoclue-2.4:2.0
22         >=x11-libs/gtk+-3.20:3
23 "
24 DEPEND="${RDEPEND}"
25 BDEPEND="
26         dev-libs/libxml2:2
27         dev-util/itstool
28         >=sys-devel/gettext-0.19.8
29         virtual/pkgconfig
30         $(vala_depend)
31         dev-libs/libgweather:2[vala]
32         media-libs/gsound[vala]
33 "
34
35 src_prepare() {
36         xdg_src_prepare
37         vala_src_prepare
38 }
39
40 src_configure() {
41         meson_src_configure -Dprofile=default
42 }
43
44 pkg_postinst() {
45         xdg_pkg_postinst
46         gnome2_schemas_update
47 }
48
49 pkg_postrm() {
50         xdg_pkg_postrm
51         gnome2_schemas_update
52 }