games-puzzle/gnome-tetravex: bump to 3.34.4
[gentoo.git] / games-puzzle / gnome-tetravex / gnome-tetravex-3.34.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit gnome.org gnome2-utils meson vala xdg
7
8 DESCRIPTION="Complete the puzzle by matching numbered tiles"
9 HOMEPAGE="https://wiki.gnome.org/Apps/Tetravex"
10
11 LICENSE="GPL-2+ CC-BY-SA-3.0"
12 SLOT="0"
13 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
14 IUSE=""
15
16 RDEPEND="
17         >=dev-libs/glib-2.40.0:2
18         >=x11-libs/gtk+-3.14:3
19 "
20 DEPEND="${RDEPEND}
21         $(vala_depend)
22         dev-libs/appstream-glib
23         dev-util/itstool
24         >=sys-devel/gettext-0.19.8
25         virtual/pkgconfig
26 "
27
28 src_prepare() {
29         xdg_src_prepare
30         vala_src_prepare
31 }
32
33 pkg_postinst() {
34         xdg_pkg_postinst
35         gnome2_schemas_update
36 }
37
38 pkg_postrm() {
39         xdg_pkg_postrm
40         gnome2_schemas_update
41 }