*/*: Discontinue Gentoo SuperH port
[gentoo.git] / games-misc / funny-manpages / funny-manpages-2.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_R="${PV:0-1}"
7 MY_P="${PN}_${PV/_p?/}"
8 DESCRIPTION="funny manpages collected from various sources"
9 HOMEPAGE="https://www.debian.org/"
10 SRC_URI="mirror://debian/pool/main/f/funny-manpages/${MY_P}.orig.tar.gz"
11
12 if [[ "${PV}" = *_p* ]] ; then
13         SRC_URI+=" mirror://debian/pool/main/f/funny-manpages/${MY_P}-${MY_R}.diff.gz"
14 fi
15
16 LICENSE="freedist" #465704
17 SLOT="0"
18 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~m68k ~mips ~ppc64 ~s390 ~x86"
19 IUSE=""
20
21 RDEPEND="virtual/man"
22
23 S="${WORKDIR}/${PN}/man"
24
25 src_prepare() {
26         if [[ "${PV}" = *_p* ]] ; then
27                 eapply "${WORKDIR}"/${MY_P}-${MY_R}.diff
28         fi
29
30         eapply_user
31
32         for f in *.[0-57-9]fun ; do
33                 mv ${f} ${f/.?fun/.6fun} || die "renaming ${f} failed"
34         done
35 }
36
37 src_install() {
38         doman *.6fun
39 }