games-kids/memonix: Stop using games.eclass
[gentoo.git] / games-kids / memonix / memonix-1.6.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit cmake-utils games
6
7 DESCRIPTION="Brain teasers, puzzle and memory games for kid's in one pack"
8 HOMEPAGE="http://www.viewizard.com/memonix/"
9 SRC_URI="http://www.viewizard.com/download/${PN}_${PV}_src.tar.bz2"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="media-libs/libsdl:0[sound,opengl,video,X]
17         media-libs/sdl-image[jpeg]
18         media-libs/sdl-mixer[vorbis]
19         !games-kids/memonix-bin"
20 RDEPEND="${DEPEND}"
21
22 S=${WORKDIR}/MemonixSourceCode
23
24 src_prepare() {
25         cmake-utils_src_prepare
26 }
27
28 src_configure() {
29         cmake-utils_src_configure
30 }
31
32 src_compile() {
33         cmake-utils_src_compile
34 }
35
36 src_install() {
37         exeinto "$(games_get_libdir)"
38         doexe ../${P}_build/Memonix
39
40         insinto "${GAMES_DATADIR}/${PN}"
41         doins ../gamedata.vfs
42
43         games_make_wrapper ${PN} "$(games_get_libdir)"/Memonix "${GAMES_DATADIR}"/${PN}
44
45         newicon ../icon48.png ${PN}.png
46         make_desktop_entry ${PN}
47
48         dodoc ReadMe.txt
49
50         prepgamesdirs
51 }