games-fps/*: drop last-rited pkgs
[gentoo.git] / games-fps / doom3-roe / doom3-roe-1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit eutils cdrom games
6
7 DESCRIPTION="Doom III: Resurrection of Evil expansion pack"
8 HOMEPAGE="http://www.doom3.com/"
9 SRC_URI=""
10
11 LICENSE="DOOM3"
12 SLOT="0"
13 KEYWORDS="-* ~amd64 ~x86"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND=">=games-fps/doom3-1.3.1302-r2"
18
19 S=${WORKDIR}
20
21 dir=${GAMES_PREFIX_OPT}/doom3
22 Ddir=${D}/${dir}
23
24 src_unpack() {
25         cdrom_get_cds Setup/Data/d3xp/pak000.pk4
26         # Change from showing "d3xp" in the "mods" menu within Doom 3
27         # The ^1 changes the text to red
28         echo '^1Resurrection of Evil' > description.txt
29 }
30
31 src_install() {
32         insinto "${dir}"/d3xp
33
34         einfo "Copying file from the disk..."
35         doins "${CDROM_ROOT}"/Setup/Data/d3xp/pak000.pk4
36
37         doins description.txt
38
39         find "${Ddir}" -exec touch '{}' +
40
41         games_make_wrapper ${PN} "doom3 +set fs_game d3xp"
42         make_desktop_entry ${PN} "Doom III - Resurrection of Evil" doom3
43
44         prepgamesdirs
45 }
46
47 pkg_postinst() {
48         games_pkg_postinst
49
50         elog "This is just the data portion of the game.  You will need to emerge"
51         elog "games-fps/doom3 to play the game."
52         echo
53 }