5ada0d983da2763e4b65ee1197d653ba7bca8909
[gentoo.git] / games-emulation / dboxfe / dboxfe-0.1.3-r1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Creates and manages configuration files for DOSBox"
7 HOMEPAGE="https://sourceforge.net/projects/dboxfe.berlios/"
8 SRC_URI="mirror://sourceforge/dboxfe.berlios/${P}.tar.bz2"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 DEPEND="dev-qt/qtgui:4
16         dev-qt/qtcore:4"
17 RDEPEND="${DEPEND}
18         >=games-emulation/dosbox-0.65"
19
20 PATCHES=(
21         "${FILESDIR}"/${P}-ldflags.patch
22 )
23
24 src_install() {
25         default
26         dobin bin/dboxfe
27         newicon res/default.png ${PN}.png
28         make_desktop_entry dboxfe "DosBoxFE"
29 }