*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / games-board / pychess / pychess-0.99.4-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_6 )
6 PYTHON_REQ_USE="sqlite"
7
8 inherit xdg-utils distutils-r1
9
10 DESCRIPTION="A chess client for Gnome"
11 HOMEPAGE="http://pychess.org/"
12 SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="gstreamer"
18
19 DEPEND="
20         dev-python/pexpect[${PYTHON_USEDEP}]
21         dev-python/psutil[${PYTHON_USEDEP}]
22         dev-python/pycairo[${PYTHON_USEDEP}]
23         dev-python/pygobject:3[${PYTHON_USEDEP}]
24         dev-python/sqlalchemy[${PYTHON_USEDEP},sqlite]
25         gnome-base/librsvg:2
26         x11-libs/gtksourceview:3.0
27         x11-libs/pango
28         x11-themes/adwaita-icon-theme
29         gstreamer? (
30                 dev-python/gst-python:1.0[${PYTHON_USEDEP}]
31                 media-libs/gstreamer:1.0
32                 media-libs/gst-plugins-base:1.0
33         )"
34 RDEPEND="${DEPEND}"
35
36 pkg_postinst() {
37         xdg_desktop_database_update
38         xdg_icon_cache_update
39         xdg_mimeinfo_database_update
40 }
41
42 pkg_postrm() {
43         xdg_desktop_database_update
44         xdg_icon_cache_update
45         xdg_mimeinfo_database_update
46 }