games-arcade/funnyboat: Add py3.8 (with new pygame py3-only)
[gentoo.git] / games-arcade / funnyboat / funnyboat-1.5_p11.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} )
6
7 inherit desktop eutils gnome2-utils python-single-r1 xdg
8
9 DESCRIPTION="A side scrolling shooter game starring a steamboat on the sea"
10 HOMEPAGE="http://funnyboat.sourceforge.net/"
11 SRC_URI="
12         mirror://sourceforge/${PN}/${P/_p*}-src.zip
13         mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
14 "
15
16 LICENSE="GPL-2 MIT"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21
22 RDEPEND="${PYTHON_DEPS}
23         >=dev-python/pygame-1.6.2[${PYTHON_USEDEP}]
24 "
25 DEPEND="${DEPEND}"
26 BDEPEND="app-arch/unzip"
27
28 S="${WORKDIR}/${PN}"
29
30 src_prepare() {
31         # Drop Debian specific patch
32         rm "${WORKDIR}"/debian/patches/use_debian_vera_ttf.patch || die
33         eapply -p1 "${WORKDIR}"/debian/patches/*.patch
34
35         xdg_src_prepare
36 }
37
38 src_install() {
39         insinto /usr/share/${PN}
40         doins -r data *.py
41         python_optimize "${ED}"/usr/share/${PN}
42
43         dodoc *.txt
44
45         make_wrapper ${PN} "${EPYTHON} main.py" /usr/share/${PN}
46
47         newicon data/titanic.png ${PN}.png
48         make_desktop_entry ${PN} "Trip on the Funny Boat"
49 }