*/*: [QA] Use consistent function definition formatting
[gentoo.git] / games-action / shootingstar / shootingstar-1.2.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools desktop gnome2-utils
6
7 # Note: currently segfaults on startup, but that's also in the previous ebuild
8 # See https://bugs.gentoo.org/607428
9
10 DESCRIPTION="A topdown shooter"
11 HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Shooting-Star-19754.shtml"
12 SRC_URI="mirror://gentoo/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="
20         media-libs/libsdl[video]
21         media-libs/sdl-image
22         media-libs/sdl-mixer
23         virtual/glu
24         virtual/opengl"
25 RDEPEND=${DEPEND}
26
27 PATCHES=(
28         "${FILESDIR}"/${PV}-gcc34.patch
29         "${FILESDIR}"/${P}-gcc44.patch
30 )
31
32 src_prepare() {
33         default
34         eautoreconf
35 }
36
37 src_install() {
38         default
39         newicon -s 128 data/textures/body1.png ${PN}.png
40         make_desktop_entry ${PN} "Shooting Star"
41 }
42
43 pkg_preinst() {
44         gnome2_icon_savelist
45 }
46
47 pkg_postinst() {
48         gnome2_icon_cache_update
49 }
50
51 pkg_postrm() {
52         gnome2_icon_cache_update
53 }