games-action/*: Update Manifest hashes
[gentoo.git] / games-action / lugaru / lugaru-20151204-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit eutils cmake-utils
6
7 DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
8 HOMEPAGE="https://bitbucket.org/osslugaru/lugaru/wiki/Home"
9 SRC_URI="mirror://gentoo/${P}.tar.bz2"
10
11 LICENSE="GPL-2+ free-noncomm CC-BY-SA-3.0"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="
17         media-libs/libpng:0
18         media-libs/libsdl[opengl,video]
19         media-libs/libvorbis
20         media-libs/openal
21         sys-libs/zlib
22         virtual/glu
23         virtual/jpeg:0
24         virtual/opengl"
25 DEPEND="${RDEPEND}
26         virtual/pkgconfig"
27
28 PATCHES=(
29         "${FILESDIR}/${P}-dir.patch"
30 )
31
32 src_prepare() {
33         cmake-utils_src_prepare
34
35         sed -i \
36                 -e "s:@GENTOO_DIR@:/usr/share/${PN}:" \
37                 Source/OpenGL_Windows.cpp || die
38 }
39
40 src_configure() {
41         mycmakeargs=(
42                 "-DCMAKE_VERBOSE_MAKEFILE=TRUE"
43                 "-DLUGARU_FORCE_INTERNAL_OPENGL=False"
44         )
45         cmake-utils_src_configure
46 }
47
48 src_compile() {
49         cmake-utils_src_compile
50 }
51
52 src_install() {
53         dobin "${WORKDIR}/${P}_build/lugaru"
54         insinto /usr/share/${PN}
55         doins -r Data/
56         newicon Source/win-res/Lugaru.png ${PN}.png
57         make_desktop_entry ${PN} Lugaru ${PN}
58 }