*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-vcs / git-spindle / git-spindle-3.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Git subcommands for interacting with central services"
11 HOMEPAGE="http://seveas.github.io/git-spindle/"
12 SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20
21 RDEPEND="
22         dev-vcs/git
23         dev-python/github3[${PYTHON_USEDEP}]
24         dev-python/docopt[${PYTHON_USEDEP}]
25         dev-python/whelk[${PYTHON_USEDEP}]
26         ${PYTHON_DEPS}"
27 DEPEND="
28         ${RDEPEND}
29         dev-python/setuptools[${PYTHON_USEDEP}]"