dev-vcs/cvsps: ppc stable wrt bug #724134
[gentoo.git] / dev-vcs / cvsps / cvsps-2.2_beta1-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="7"
5
6 inherit eutils toolchain-funcs
7
8 MY_P="${P/_beta/b}"
9 DESCRIPTION="Generates patchset information from a CVS repository"
10 HOMEPAGE="http://www.catb.org/~esr/cvsps/"
11 SRC_URI="http://www.cobite.com/cvsps/${MY_P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
16 IUSE=""
17
18 RDEPEND="sys-libs/zlib"
19 DEPEND="${RDEPEND}"
20
21 S="${WORKDIR}/${MY_P}"
22
23 PATCHES=(
24         "${FILESDIR}"/${PN}-2.1-build.patch
25         "${FILESDIR}"/${P}-solaris.patch
26 )
27
28 src_prepare() {
29         default
30
31         # no configure around
32         if [[ ${CHOST} == *-solaris* ]] ; then
33                 sed -i -e '/^LDLIBS+=/s/$/ -lsocket/' Makefile || die
34         fi
35         tc-export CC
36 }
37
38 src_install() {
39         dobin cvsps
40         doman cvsps.1
41         dodoc README CHANGELOG
42 }