*/*: Drop stable ia64 keywords
[gentoo.git] / dev-vcs / cvs2svn / cvs2svn-2.4.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7 DISTUTILS_SINGLE_IMPL=1
8
9 inherit distutils-r1
10
11 FILEVER="49237"
12
13 DESCRIPTION="Convert a CVS repository to a Subversion repository"
14 HOMEPAGE="http://cvs2svn.tigris.org/"
15 SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~alpha amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
20 IUSE="bazaar git test"
21 RESTRICT="!test? ( test )"
22
23 DEPEND=">=dev-vcs/subversion-1.0.9"
24 RDEPEND="${DEPEND}
25         bazaar? ( >=dev-vcs/bzr-1.13 )
26         git? ( >=dev-vcs/git-1.5.4.4 )
27         dev-vcs/rcs"
28
29 pkg_setup() {
30         python-single-r1_pkg_setup
31 }
32
33 src_prepare() {
34         distutils-r1_src_prepare
35         python_fix_shebang .
36 }
37
38 src_compile() {
39         distutils-r1_src_compile
40         emake man
41 }
42
43 src_install() {
44         distutils-r1_src_install
45         insinto "/usr/share/${PN}"
46         doins -r contrib cvs2{svn,git,bzr}-example.options
47         doman *.1
48 }
49
50 python_test() {
51         # Need this because subversion is localized, but the tests aren't
52         export LC_ALL=C
53         "${PYTHON}" -W ignore run-tests.py
54 }
55
56 pkg_postinst() {
57         elog "Additional scripts and examples have been installed to:"
58         elog "  /usr/share/${PN}/"
59 }