*/*: [QA] Fix trivial cases of MissingTestRestrict
[gentoo.git] / dev-util / uncrustify / uncrustify-0.66.1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 if [[ $PV == *9999* ]]; then
7         EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
8         scm_eclass=git-r3
9 else
10         KEYWORDS="amd64 x86 ~amd64-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
11         SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
12         S=${WORKDIR}/${PN}-${P}
13 fi
14
15 inherit cmake-utils ${scm_eclass}
16
17 PYTHON_COMPAT=( python2_7 )
18
19 inherit python-any-r1
20
21 DESCRIPTION="C/C++/C#/D/Java/Pawn code indenter and beautifier"
22 HOMEPAGE="http://uncrustify.sourceforge.net/"
23
24 LICENSE="GPL-2"
25 SLOT="0"
26 IUSE="test"
27 RESTRICT="!test? ( test )"
28
29 DEPEND="test? ( ${PYTHON_DEPS} )"
30
31 python_test() {
32         cd tests
33         ${EPYTHON} run_tests.py || die "tests failed"
34 }