*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / umockdev / umockdev-0.9.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit python-any-r1
8
9 DESCRIPTION="Mock hardware devices for creating unit tests"
10 HOMEPAGE="https://github.com/martinpitt/umockdev/"
11 SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
12
13 LICENSE="LGPL-2.1+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="static-libs test"
17
18 RDEPEND="dev-libs/libgudev:=
19         virtual/libudev:=
20         >=dev-libs/glib-2.32:2"
21 DEPEND="${RDEPEND}
22         test? ( ${PYTHON_DEPS} )
23         app-arch/xz-utils
24         virtual/pkgconfig"
25
26 RESTRICT="test"
27
28 PATCHES=(
29         "${FILESDIR}"/${P}-sysmacros.patch #579988
30 )
31
32 src_configure() {
33         econf $(use_enable static-libs static)
34 }