Convert all URIs for launchpad.net from http to https
[gentoo.git] / dev-util / umockdev / umockdev-0.8.10.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_3,3_4} )
7
8 inherit python-any-r1 autotools-utils
9
10 DESCRIPTION="Mock hardware devices for creating unit tests"
11 HOMEPAGE="https://github.com/martinpitt/umockdev/"
12 SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
13
14 LICENSE="LGPL-2.1+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="static-libs test"
18
19 RDEPEND="virtual/libgudev:=
20         virtual/libudev:=
21         >=dev-libs/glib-2.32:2"
22 DEPEND="${RDEPEND}
23         test? ( ${PYTHON_DEPS} )
24         app-arch/xz-utils
25         virtual/pkgconfig"
26
27 RESTRICT="test"