9be96213f4c9a78cd8b851fbd1df1b28a134ebb2
[gentoo.git] / dev-util / shadowman / shadowman-2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Unified compiler shadow link directory updater"
7 HOMEPAGE="https://github.com/mgorny/shadowman"
8 SRC_URI="https://github.com/mgorny/shadowman/archive/v${PV}.tar.gz -> ${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 m68k ~mips ppc ppc64 ~riscv s390 sparc x86"
13 IUSE=""
14
15 RDEPEND="app-admin/eselect"
16 DEPEND="${RDEPEND}"
17
18 src_install() {
19         # tool modules are split into their respective packages
20         emake DESTDIR="${D}" prefix="${EPREFIX}"/usr install \
21                 INSTALL_MODULES_TOOL=""
22         keepdir /usr/share/shadowman/tools
23 }