*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / setconf / setconf-0.6.7.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 PYTHON_COMPAT=( python{2_7,3_6} )
6 inherit python-single-r1
7
8 DESCRIPTION="A small python based utility used to change configuration files"
9 HOMEPAGE="http://setconf.roboticoverlords.org/"
10 SRC_URI="http://${PN}.roboticoverlords.org/${P}.tar.xz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15
16 RDEPEND=${PYTHON_DEPS}
17
18 # "REQUIRED_USE is needed to have a (un-)nice error when someone disabled all of python3" -mgorny
19 REQUIRED_USE=${PYTHON_REQUIRED_USE}
20
21 pkg_setup() {
22         python-single-r1_pkg_setup
23 }
24
25 src_unpack() {
26         unpack ${A}
27         cd "${S}" || die
28         unpack "./${PN}.1.gz"
29 }
30
31 src_prepare() {
32         python_fix_shebang -f "${PN}.py"
33 }
34
35 src_install() {
36         python_doscript "${PN}.py"
37         dosym "${PN}.py" "/usr/bin/${PN}"
38         doman "${PN}.1"
39 }