a3aa0dbf6f7d2a78c7acf3d462e235236a3bba4c
[gentoo.git] / dev-util / lttng-ust / lttng-ust-2.11.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 MY_P="${P/_rc/-rc}"
9 MY_SLOT="$(ver_cut 1-2)"
10
11 DESCRIPTION="Linux Trace Toolkit - UST library"
12 HOMEPAGE="http://lttng.org"
13 SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0/${MY_SLOT}"
17 KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
18 IUSE="examples numa"
19
20 DEPEND="
21         dev-libs/userspace-rcu:=
22         numa? ( sys-process/numactl )
23         "
24 RDEPEND="${DEPEND}"
25
26 PATCHES=("${FILESDIR}"/${P}-fno-common.patch)
27
28 S="${WORKDIR}"/${MY_P}
29
30 src_prepare() {
31         default
32         if ! use examples; then
33                 sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
34         fi
35         eautoreconf
36 }
37
38 src_configure() {
39         econf \
40                 $(use_enable numa) \
41                 --docdir=/usr/share/doc/${PF}
42 }