671fae56339228c5686cf7956a9328efb04ca3c3
[gentoo.git] / dev-util / lttng-tools / lttng-tools-2.10.9.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit linux-info
7
8 MY_P="${P/_rc/-rc}"
9 MY_SLOT="$(ver_cut 1-2)"
10
11 DESCRIPTION="Linux Trace Toolkit - next generation"
12 HOMEPAGE="http://lttng.org"
13 SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0/${MY_SLOT}"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="+ust"
19
20 DEPEND="dev-libs/userspace-rcu:=
21         dev-libs/popt
22         dev-libs/libxml2
23         ust? ( dev-util/lttng-ust:= )
24 "
25 RDEPEND="${DEPEND}"
26
27 S="${WORKDIR}/${MY_P}"
28
29 pkg_pretend() {
30         if kernel_is -lt 2 6 27; then
31                 ewarn "${PN} require Linux kernel >= 2.6.27"
32                 ewarn "   pipe2(), epoll_create1() and SOCK_CLOEXEC are needed to run"
33                 ewarn "   the session daemon. There were introduce in the 2.6.27"
34         fi
35 }
36
37 src_configure() {
38         econf \
39                 $(usex ust "" --without-lttng-ust) \
40                 --docdir=/usr/share/doc/${PF}
41 }