*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-util / lcov / lcov-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 if [[ ${PV} == "9999" ]] ; then
7         EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
8         inherit git-r3
9 else
10         SRC_URI="mirror://sourceforge/ltp/${P}.tar.gz"
11         KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
12 fi
13
14 inherit prefix
15
16 DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
17 HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"
18
19 LICENSE="GPL-2+"
20 SLOT="0"
21 IUSE="png"
22
23 RDEPEND="
24         dev-lang/perl
25         dev-perl/JSON
26         dev-perl/PerlIO-gzip
27         png? ( dev-perl/GD[png] )
28 "
29
30 src_prepare() {
31         default
32         if use prefix; then
33                 hprefixify bin/*.{pl,sh}
34         fi
35 }
36
37 src_compile() { :; }
38
39 src_install() {
40         emake PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
41 }