*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / gprof2dot / gprof2dot-2016.10.13.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7 PYTHON_REQ_USE='xml'
8
9 inherit distutils-r1
10
11 DESCRIPTION="Converts profiling output to dot graphs"
12 HOMEPAGE="https://github.com/jrfonseca/gprof2dot"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="LGPL-3+"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20
21 RDEPEND="${PYTHON_DEPS}"
22 DEPEND="${RDEPEND}"