*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / gertty / gertty-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 python3_6 python3_7 )
6
7 inherit distutils-r1
8
9 DESCRIPTION="Gertty is a console-based interface to the Gerrit Code Review system."
10 HOMEPAGE="https://pypi.org/project/gertty/"
11 if [[ ${PV} == *9999 ]];then
12         inherit git-r3
13         EGIT_REPO_URI="https://opendev.org/ttygroup/gertty"
14         EGIT_BRANCH="master"
15 else
16         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
17         KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 fi
19
20 LICENSE="Apache-2.0"
21 SLOT="0"
22 IUSE=""
23
24 CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
25 DEPEND="
26         dev-python/setuptools[${PYTHON_USEDEP}]
27         ${CDEPEND}"
28 RDEPEND="
29         ${CDEPEND}
30         >=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
31         !~dev-python/urwid-1.3.0[${PYTHON_USEDEP}]
32         >=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
33         >=dev-python/git-python-0.3.7[${PYTHON_USEDEP}]
34         dev-python/python-dateutil[${PYTHON_USEDEP}]
35         >=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
36         <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
37         $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' 'python2*')
38         >=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
39         >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
40         >=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]
41         >=dev-python/ply-3.4[${PYTHON_USEDEP}]
42         dev-python/six[${PYTHON_USEDEP}]"