*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / flawfinder / flawfinder-2.0.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python2_7 python3_{6,7} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Examines C/C++ source code for security flaws"
11 HOMEPAGE="https://www.dwheeler.com/flawfinder/"
12 SRC_URI="https://www.dwheeler.com/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
17 IUSE=""
18
19 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
20
21 DEPEND="${PYTHON_DEPS}"
22 RDEPEND="${DEPEND}"
23
24 src_prepare() {
25         sed -i "s/${PN}.1.gz/${PN}.1/g" setup.py || die 'sed failed.'
26         default
27 }
28
29 python_test() {
30         emake test
31 }
32
33 python_install_all() {
34         local DOCS=( announcement ChangeLog README.md ${PN}.pdf )
35         distutils-r1_python_install_all
36 }