dev-util/diffoscope: bump up to 146
[gentoo.git] / dev-util / diffoscope / diffoscope-146.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7} )
7 DISTUTILS_USE_SETUPTOOLS=rdepend
8 inherit distutils-r1
9
10 DESCRIPTION="Will try to get to the bottom of what makes files or directories different"
11 HOMEPAGE="https://diffoscope.org/ https://pypi.org/project/diffoscope/"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-3+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="acl binutils bzip2 libcaca colord cpio +diff docx dtc e2fsprogs file
18 find gettext gif gpg gzip haskell hdf5 hex imagemagick iso java llvm
19 mono opendocument pascal pdf postscript R rpm sqlite squashfs
20 ssh tar tcpdump xz zip zstd"
21
22 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
23 RDEPEND="dev-python/python-magic[${PYTHON_USEDEP}]
24         dev-python/libarchive-c[${PYTHON_USEDEP}]
25         dev-python/distro[${PYTHON_USEDEP}]
26         acl? ( sys-apps/acl )
27         binutils? ( sys-devel/binutils )
28         bzip2? ( app-arch/bzip2 )
29         libcaca? ( media-libs/libcaca )
30         colord? ( x11-misc/colord )
31         cpio? ( app-arch/cpio )
32         diff? ( sys-apps/diffutils )
33         docx? ( app-text/docx2txt )
34         dtc? ( sys-apps/dtc )
35         e2fsprogs? ( sys-fs/e2fsprogs )
36         file? ( sys-apps/file )
37         find? ( sys-apps/findutils )
38         gettext? ( sys-devel/gettext )
39         gif? ( media-libs/giflib )
40         gpg? ( app-crypt/gnupg )
41         gzip? ( app-arch/gzip )
42         haskell? ( dev-lang/ghc )
43         hdf5? ( sci-libs/hdf5 )
44         hex? ( app-editors/vim-core )
45         imagemagick? ( media-gfx/imagemagick )
46         iso? ( virtual/cdrtools )
47         java? ( virtual/jdk )
48         llvm? ( sys-devel/llvm )
49         mono? ( dev-lang/mono )
50         opendocument? ( app-text/odt2txt )
51         pascal? ( dev-lang/fpc )
52         pdf? (
53                 app-text/pdftk
54                 app-text/poppler
55                 dev-python/PyPDF2[${PYTHON_USEDEP}]
56         )
57         postscript? ( app-text/ghostscript-gpl )
58         R? ( dev-lang/R )
59         rpm? ( app-arch/rpm )
60         sqlite? ( dev-db/sqlite:3 )
61         squashfs? ( sys-fs/squashfs-tools )
62         ssh? ( net-misc/openssh )
63         tar? ( app-arch/tar )
64         tcpdump? ( net-analyzer/tcpdump )
65         xz? ( app-arch/xz-utils )
66         zip? ( app-arch/unzip )
67         zstd? ( app-arch/zstd )
68 "
69 # Presence if filemagic's magic.py breaks imports
70 # of dev-python/python-magic: https://bugs.gentoo.org/716482
71 RDEPEND+=" !dev-python/filemagic"