dev-util/clair: 2.1.3 bump
[gentoo.git] / dev-util / clair / clair-2.1.3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit go-module
6
7 DESCRIPTION="Vulnerability Static Analysis for Containers"
8 HOMEPAGE="https://github.com/coreos/clair"
9
10 EGO_SUM=(
11         "github.com/beorn7/perks v0.0.0-20160804104726-4c0e84591b9a"
12         "github.com/beorn7/perks v0.0.0-20160804104726-4c0e84591b9a/go.mod"
13         "github.com/coreos/pkg v0.0.0-20160727233714-3ac0863d7acf"
14         "github.com/coreos/pkg v0.0.0-20160727233714-3ac0863d7acf/go.mod"
15         "github.com/davecgh/go-spew v1.0.1-0.20160907170601-6d212800a42e"
16         "github.com/davecgh/go-spew v1.0.1-0.20160907170601-6d212800a42e/go.mod"
17         "github.com/fernet/fernet-go v0.0.0-20151007213151-1b2437bc582b"
18         "github.com/fernet/fernet-go v0.0.0-20151007213151-1b2437bc582b/go.mod"
19         "github.com/golang/protobuf v0.0.0-20170427213220-18c9bb326172"
20         "github.com/golang/protobuf v0.0.0-20170427213220-18c9bb326172/go.mod"
21         "github.com/guregu/null v3.0.2-0.20160228005316-41961cea0328+incompatible"
22         "github.com/guregu/null v3.0.2-0.20160228005316-41961cea0328+incompatible/go.mod"
23         "github.com/hashicorp/golang-lru v0.0.0-20160813221303-0a025b7e63ad"
24         "github.com/hashicorp/golang-lru v0.0.0-20160813221303-0a025b7e63ad/go.mod"
25         "github.com/julienschmidt/httprouter v1.1.0"
26         "github.com/julienschmidt/httprouter v1.1.0/go.mod"
27         "github.com/lib/pq v0.0.0-20170324204654-2704adc878c2"
28         "github.com/lib/pq v0.0.0-20170324204654-2704adc878c2/go.mod"
29         "github.com/matttproud/golang_protobuf_extensions v1.0.1"
30         "github.com/matttproud/golang_protobuf_extensions v1.0.1/go.mod"
31         "github.com/pborman/uuid v0.0.0-20160209185913-a97ce2ca70fa"
32         "github.com/pborman/uuid v0.0.0-20160209185913-a97ce2ca70fa/go.mod"
33         "github.com/pmezard/go-difflib v0.0.0-20151028094244-d8ed2627bdf0"
34         "github.com/pmezard/go-difflib v0.0.0-20151028094244-d8ed2627bdf0/go.mod"
35         "github.com/prometheus/client_golang v0.8.0"
36         "github.com/prometheus/client_golang v0.8.0/go.mod"
37         "github.com/prometheus/client_model v0.0.0-20170216185247-6f3806018612"
38         "github.com/prometheus/client_model v0.0.0-20170216185247-6f3806018612/go.mod"
39         "github.com/prometheus/common v0.0.0-20170427095455-13ba4ddd0caa"
40         "github.com/prometheus/common v0.0.0-20170427095455-13ba4ddd0caa/go.mod"
41         "github.com/prometheus/procfs v0.0.0-20170502131342-d098ca18df8b"
42         "github.com/prometheus/procfs v0.0.0-20170502131342-d098ca18df8b/go.mod"
43         "github.com/remind101/migrate v0.0.0-20160423010909-d22d647232c2"
44         "github.com/remind101/migrate v0.0.0-20160423010909-d22d647232c2/go.mod"
45         "github.com/sirupsen/logrus v0.11.5"
46         "github.com/sirupsen/logrus v0.11.5/go.mod"
47         "github.com/stretchr/testify v1.1.4"
48         "github.com/stretchr/testify v1.1.4/go.mod"
49         "github.com/tylerb/graceful v1.2.15"
50         "github.com/tylerb/graceful v1.2.15/go.mod"
51         "golang.org/x/sys v0.0.0-20170427041856-9ccfe848b9db/go.mod"
52         "gopkg.in/yaml.v2 v2.0.0-20170407172122-cd8b52f8269e"
53         "gopkg.in/yaml.v2 v2.0.0-20170407172122-cd8b52f8269e/go.mod"
54         )
55 go-module_set_globals
56 SRC_URI="https://github.com/coreos/clair/archive/v${PV}.tar.gz -> ${P}.tar.gz
57         ${EGO_SUM_SRC_URI}"
58
59 LICENSE="Apache-2.0"
60 SLOT="0"
61 KEYWORDS="~amd64"
62
63 COMMON_DEPEND="acct-group/clair
64         acct-user/clair"
65         DEPEND="${COMMON_DEPEND}"
66 RDEPEND="app-arch/rpm
67         app-arch/xz-utils
68         dev-vcs/git
69         ${COMMON_DEPEND}
70         !!sci-visualization/xd3d" # File collision (Bug #621044)
71
72 src_compile() {
73         go build -o bin/${PN} ./cmd/${PN}  || die
74 }
75
76 src_install() {
77         dobin bin/${PN}
78         dodoc {README,ROADMAP,CONTRIBUTING}.md
79         insinto /usr/share/${PN}
80         doins -r contrib
81         insinto /etc/${PN}
82         doins config.example.yaml
83
84         newinitd "${FILESDIR}"/${PN}.initd ${PN}
85         newconfd "${FILESDIR}"/${PN}.confd ${PN}
86         keepdir /var/log/${PN}
87         fowners ${PN}:${PN} /var/log/${PN}
88 }