dev-libs/leatherman: remove installing vendored boost library
[gentoo.git] / dev-util / clair / clair-2.0.8.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit user golang-build golang-vcs-snapshot
6
7 EGO_PN="github.com/coreos/clair"
8 EGIT_COMMIT="v${PV}"
9 ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
10 KEYWORDS="~amd64"
11
12 DESCRIPTION="Vulnerability Static Analysis for Containers"
13 HOMEPAGE="https://github.com/coreos/clair"
14 SRC_URI="${ARCHIVE_URI}"
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 IUSE=""
18
19 RDEPEND="app-arch/rpm
20         app-arch/xz-utils
21         dev-vcs/git
22         !!sci-visualization/xd3d" # File collision (Bug #621044)
23
24 pkg_setup() {
25         enewgroup ${PN}
26         enewuser ${PN} -1 -1 -1 ${PN}
27 }
28
29 src_compile() {
30         GOPATH="${S}" go build -o bin/${PN} -v ${EGO_PN}/cmd/${PN}  || die
31 }
32
33 src_install() {
34         dobin bin/${PN}
35         pushd src/${EGO_PN} || die
36         dodoc {README,ROADMAP,CONTRIBUTING}.md
37         insinto /etc/${PN}
38         doins config.example.yaml
39         popd || die
40
41         newinitd "${FILESDIR}"/${PN}.initd ${PN}
42         newconfd "${FILESDIR}"/${PN}.confd ${PN}
43         keepdir /var/log/${PN}
44         fowners ${PN}:${PN} /var/log/${PN}
45 }