*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / cdiff / cdiff-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 PYTHON_COMPAT=( python{2_7,3_6} )
7
8 inherit distutils-r1 git-r3
9
10 DESCRIPTION="Colored, side-by-side diff terminal viewer"
11 HOMEPAGE="https://github.com/ymattw/cdiff"
12 EGIT_REPO_URI="https://github.com/ymattw/cdiff.git"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE=""
18
19 DEPEND="
20         !<app-misc/colordiff-1.0.13-r1
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         sys-apps/less"
23 RDEPEND="${DEPEND}"
24
25 PATCHES=( "${FILESDIR}"/${PN}-0.9.2-disable-unimportant-failing-test.patch )
26
27 DOCS=( CHANGES.rst README.rst )
28
29 python_test() {
30         ${PYTHON} tests/test_cdiff.py || die "Unit tests failed."
31
32         ./tests/regression.sh || die "Regression tests failed."
33 }