*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / cdiff / cdiff-1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Colored, side-by-side diff terminal viewer"
11 HOMEPAGE="https://github.com/ymattw/cdiff"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
17
18 DEPEND="
19         !<app-misc/colordiff-1.0.13-r1
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         sys-apps/less"
22 RDEPEND="${DEPEND}"
23
24 DOCS=( CHANGES.rst README.rst )
25
26 RESTRICT="test"
27
28 python_test() {
29         ${PYTHON} tests/test_cdiff.py || die "Unit tests failed."
30
31         ./tests/regression.sh || die "Regression tests failed."
32 }