*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / catfish / catfish-1.4.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python{2_7,3_6} )
6
7 inherit distutils-r1 xdg-utils
8
9 DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
10 HOMEPAGE="https://docs.xfce.org/apps/catfish/start"
11 SRC_URI="https://archive.xfce.org/src/apps/catfish/${PV%.*}/${P}.tar.bz2"
12
13 # yep, GPL-2 only
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ~ppc x86"
17
18 RDEPEND="
19         dev-libs/gobject-introspection
20         dev-python/dbus-python[${PYTHON_USEDEP}]
21         dev-python/pexpect[${PYTHON_USEDEP}]
22         dev-python/pygobject:3[${PYTHON_USEDEP}]
23         x11-libs/gdk-pixbuf[introspection]
24         x11-libs/gtk+:3[introspection]
25         x11-libs/pango[introspection]
26         virtual/freedesktop-icon-theme
27 "
28 DEPEND="
29         dev-python/python-distutils-extra[${PYTHON_USEDEP}]
30         sys-devel/gettext
31 "
32
33 python_install() {
34         distutils-r1_python_install
35         rm -r "${ED}"/usr/share/doc/catfish || die
36 }
37
38 pkg_postinst() {
39         xdg_icon_cache_update
40         xdg_desktop_database_update
41 }
42
43 pkg_postrm() {
44         xdg_icon_cache_update
45         xdg_desktop_database_update
46 }