*/*: Clean PYTHON_COMPAT of obsolete impls
[gentoo.git] / dev-util / buildbot-pkg / buildbot-pkg-0.9.12.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 PYTHON_REQ_USE="sqlite"
6 PYTHON_COMPAT=( python2_7 python3_6 )
7
8 EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"
9
10 [[ ${PV} == *9999 ]] && inherit git-r3
11 inherit distutils-r1
12
13 MY_PV="${PV/_p/.post}"
14 MY_P="${PN}-${MY_PV}"
15
16 DESCRIPTION="BuildBot common www build tools for packaging releases"
17 HOMEPAGE="https://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.org/project/buildbot-pkg/"
18 [[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
19
20 LICENSE="GPL-2"
21 SLOT="0"
22
23 if [[ ${PV} == *9999 ]]; then
24         KEYWORDS=""
25 else
26         KEYWORDS="~amd64"
27 fi
28
29 # No real integration tests for this pkg.
30 # all tests are related to making releases and final checks for distribution
31
32 RDEPEND="
33         ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
34         dev-python/mock[${PYTHON_USEDEP}]
35 "
36
37 DEPEND="${RDEPEND}
38         >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
39 "
40
41 S=${WORKDIR}/${MY_P}
42
43 python_install_all() {
44         distutils-r1_python_install_all
45 }