*/*: Discontinue Gentoo SuperH port
[gentoo.git] / dev-tex / latexmk / latexmk-465.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit bash-completion-r1
7
8 DESCRIPTION="Perl script for automatically building LaTeX documents"
9 HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
10 SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
15
16 RDEPEND="virtual/latex-base
17         dev-lang/perl"
18 DEPEND="${RDEPEND}
19         app-arch/unzip"
20
21 S="${WORKDIR}/${PN}"
22
23 src_install() {
24         newbin latexmk.pl latexmk
25         doman latexmk.1
26         dodoc CHANGES README latexmk.pdf latexmk.txt
27         dodoc -r example_rcfiles extra-scripts
28         newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
29 }