*/*: Drop stable ia64 keywords
[gentoo.git] / dev-tex / envlab / envlab-1.2-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit latex-package
7
8 DESCRIPTION="A LaTeX module to format envelopes"
9 HOMEPAGE="https://ctan.org/pkg/envlab"
10 # downloaded from:
11 # ftp://ftp.ctan.org/pub/tex-archive/macros/latex/contrib/${PN}.tar.gz
12 SRC_URI="mirror://gentoo/${P}.tar.gz"
13 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
14
15 LICENSE="LPPL-1.2"
16 SLOT="0"
17 IUSE=""
18
19 DEPEND=""
20
21 TEXMF=/usr/share/texmf-site
22
23 S="${WORKDIR}/${PN}"
24
25 src_compile() {
26         export VARTEXFONTS="${T}/fonts"
27         ebegin "Compiling ${PN}"
28         latex envlab.ins || die "compiling #1 failed"
29         pdflatex elguide.tex || die "compiling #2 failed"
30         pdflatex elguide.tex || die "compiling #2 failed"
31         pdflatex envlab.drv || die "compiling #3 failed"
32         pdflatex envlab.drv || die "compiling #3 failed"
33         eend
34 }
35
36 src_install() {
37         latex-package_src_install
38
39         insinto ${TEXMF}/tex/latex/${PN}
40         doins *.cfg
41
42         dodoc readme.v12
43 }