*/*: dekeyword ruby on ia64
[gentoo.git] / dev-ruby / zentest / zentest-4.11.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 USE_RUBY="ruby22 ruby23 ruby24 ruby25"
7
8 RUBY_FAKEGEM_NAME=ZenTest
9
10 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
11 RUBY_FAKEGEM_EXTRADOC="README.txt History.txt example.txt example1.rb example2.rb example_dot_autotest.rb"
12
13 inherit ruby-fakegem
14
15 DESCRIPTION="Testing tools: zentest, unit_diff, autotest, multiruby, and Test::Rails"
16 HOMEPAGE="https://github.com/seattlerb/zentest"
17 LICENSE="Ruby"
18
19 KEYWORDS="~alpha amd64 arm ~arm64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
20 SLOT="0"
21 IUSE=""
22
23 ruby_add_bdepend "
24         test? (
25                 >=dev-ruby/hoe-2.10
26                 dev-ruby/hoe-seattlerb
27                 dev-ruby/minitest:5
28         )"