dev-python/objgraph: keyworded 3.4.1 for ia64, bug #717946
[gentoo.git] / dev-ruby / strptime / strptime-0.2.3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
6
7 RUBY_FAKEGEM_RECIPE_DOC="rdoc"
8 RUBY_FAKEGEM_EXTRADOC="README.md"
9
10 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
11
12 RUBY_FAKEGEM_GEMSPEC="strptime.gemspec"
13
14 RUBY_FAKEGEM_BINWRAP=""
15
16 inherit multilib ruby-fakegem
17
18 DESCRIPTION="A fast strptime/strftime engine which uses VM"
19 HOMEPAGE="https://github.com/nurse/strptime"
20 SRC_URI="https://github.com/nurse/strptime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
21
22 LICENSE="BSD-2"
23 SLOT="0"
24 KEYWORDS="~amd64"
25 IUSE=""
26
27 all_ruby_prepare() {
28         sed -i -e 's/git ls-files -z/find -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
29 }
30
31 each_ruby_configure() {
32         ${RUBY} -Cext/strptime extconf.rb || die
33 }
34
35 each_ruby_compile() {
36         emake -Cext/strptime V=1
37         cp ext/strptime/strptime$(get_modname) lib/strptime/ || die
38 }