5233d1dcc45c230df6c1169782a19a32812224dd
[gentoo.git] / dev-ruby / ruby2ruby / ruby2ruby-2.4.4.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 USE_RUBY="ruby24 ruby25 ruby26 ruby27"
7
8 RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
9
10 inherit ruby-fakegem
11
12 DESCRIPTION="Generates readable ruby from ParseTree"
13 HOMEPAGE="https://github.com/seattlerb/ruby2ruby"
14
15 LICENSE="GPL-2"
16 SLOT="2"
17 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
18 IUSE="test"
19
20 ruby_add_rdepend "
21         >=dev-ruby/sexp_processor-4.6.0:4
22         >=dev-ruby/ruby_parser-3.1:3
23 "
24 ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.3:5 >=dev-ruby/sexp_processor-4.10.0:4 )"
25
26 all_ruby_prepare() {
27         sed -i -e '/plugin :isolate/ s:^:#:' Rakefile || die
28 }
29
30 each_ruby_test() {
31         ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
32 }