*/*: dekeyword ruby on ia64
[gentoo.git] / dev-ruby / rspec-mocks / rspec-mocks-3.9.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 USE_RUBY="ruby24 ruby25 ruby26"
6
7 RUBY_FAKEGEM_RECIPE_TEST="rspec3"
8
9 #RUBY_FAKEGEM_RECIPE_DOC="none"
10 RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
11
12 RUBY_FAKEGEM_GEMSPEC="rspec-mocks.gemspec"
13
14 inherit ruby-fakegem
15
16 DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
17 HOMEPAGE="https://github.com/rspec/rspec-mocks"
18 SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
19
20 LICENSE="MIT"
21 SLOT="3"
22 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
23 IUSE=""
24
25 SUBVERSION="$(ver_cut 1-2)"
26
27 ruby_add_rdepend "=dev-ruby/rspec-support-${SUBVERSION}*
28         >=dev-ruby/diff-lcs-1.2.0 =dev-ruby/diff-lcs-1*"
29
30 ruby_add_bdepend "
31         test? (
32                 >=dev-ruby/rspec-core-3.3.0:3
33                 >=dev-ruby/rspec-expectations-2.99.0:3
34         )"
35
36 all_ruby_prepare() {
37         # Don't set up bundler: it doesn't understand our setup.
38         sed -i -e '/[Bb]undler/d' Rakefile || die
39
40         # Remove the Gemfile to avoid running through 'bundle exec'
41         rm Gemfile || die
42
43         # Remove .rspec options to avoid dependency on newer rspec when
44         # bootstrapping.
45         rm .rspec || die
46
47         sed -i -e '1irequire "spec_helper"' spec/rspec/mocks/any_instance_spec.rb || die
48 }